Announcement

Collapse
No announcement yet.

Drive Train wheels not moving together.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Drive Train wheels not moving together.

    The drive-train on our robot has the wheels on the right going faster than the wheels on the left. If there any way we can correct this problem? We have not programmed it to do this, it just started happening.

  • #2
    Can you post your program please? How much faster are they going. Is there a gear train, or direct drive?

    Comment


    • #3
      I have a modified drivetrain. It's a little longer than the regular drive train. But, here is my program.



      Comment


      • #4
        I think you are running into timing problems. This thread here talks about them http://www.vexiqforum.com/forum/main...rmware-problem

        The blocks sometimes think they are done when they are not. You have two sets of motors that need to report in their status.

        I'd put a wait in front of each speed change to let the motors catch up with what they are doing. It may look a little jumpy when running, but should do the trick.

        Let us know how you make out!!!

        Comment


        • #5
          By how much are they going faster? Just so it doesn't quite drive straight or so much so that it spins on the spot when it's supposed to be going forwards?

          Comment


          • #6
            It just pulls slightly to the left. The right wheels go a tad faster than the left. We use Modkit by the way.

            Comment


            • #7
              Can you post a video to YouTube? The issue sounds more like a mechanical one (i.e. play in the chassis somewhere) rather than a motor one.

              Comment

              Working...
              X